Прошивка телефонов Honor в Москве, перепрошивка — Сервисный центр

Базовая настройка коммутаторов и маршрутизаторов huawei

Basic

вход в режим конфигурирования

system view

вернуться на уровень назад
quit

команда отрицания (аналогично no в cisco)

undo

настройка пароля доступа по консольному порту 

user-interface console 0

authentication-mode password

set 

authentication password cipher …

настройка пароля доступа через виртуальный терминал

VLAN Principles

создание

vlan batch

interface

port link-type access

port 

access default vlan …

interface

port link-type trunk

port trunk allow-pass vlan

port link-type hybrid

port hybrid untagged vlan …

port hybrid tagged vlan …

port hybrid pvid vlan …

создание L3 интерфейса

interface Vlanif  

ip address

Link Aggregation


L2 LAG

interface Eth-trunk 1 — создали LAG группу


interface

eth-trunk 1 -забиндили интерфейс

interface

eth-trunk 1 -забиндили интерфейс

L3 LAG

interface Eth-trunk 1 — создали LAG группу

// переход  интерфейса к L3

undo portswitch 

ip address 

interface

eth-trunk 1 -забиндили интерфейс

interface

eth-trunk 1 -забиндили интерфейс

LACP(link aggregation control protocol)

system-view

lacp priority … (The smaller the LACP system priority value, the higher the LACP system priority.)

int Eth-trunk 1 — создали LAG группу

mode lacp-static -выбрали режим

lacp preference … (The smaller the LACP interface priority value, the higher the LACP interface priority)

STP

выбор стандарта

stp mode stp

активируется глобально и на интерфейсе 

stp enable 

вручную указываем корень в топологии

stp root primary

stp root secondary

вручную указываем bridge priority

stp priority 32768

на интерфейсе

stp disable

stp port priority …

display stp brief

display stp instance 0 brief

RSTP

выбор стандарта

stp mode rstp

выключает edge порт при получении bpdu

stp bpdu-protection 

на интерфейсе:

stp root-protection (включается на портах корневого коммутатора, при получении лучшего bpdu порт переходит в состояние root-inconsistent — несогласованность корня)

используется на клиентских портах

stp edged-port enable

stp bpdu-filter enable (не отправляет и не принимает bpdu)

stp loop-protection (технология защиты от петель в моменты реконвергенции stp. если порт перестает получать bpdu он не переходит в состояние forwarding, а переходит в состояние loop-inconsistent)

MSTP

stp mode mstp

stp region-configuration

region-name parapampam

instance 1 vlan 2 to 10

instance 1 vlan 11 to 20

active region-configuration

display stp region-configuration

Static routing

создаем статический маршрут

ip route-static ipaddress { mask | mask-length } interface-type interface-number [ nexthopaddress ] preference …

создаем маршрут по умолчанию

ip route-static 0.0.0.0 0.0.0.0 nexthopaddress

RIP

basic:

rip 1

version 2 (по умолчанию version 1)

network 10.0.0.0

анонс маршрута по умолчанию через rip

default-route originate

выключаем автоматическую суммаризацию маршрутов

undo summary

суммаризация маршрутов на интерфейсе

int g0/0/0

rip summary-address 172.16.0.0 255.255.0.0.

debug

debugging rip 1,

disp debugging

terminal debugging

undo debugging rip 1 or undo debugging all !!!

RIP Metric

int g0/0/0

устанавливает cost на порту для входящих маршрутов

rip metricin 

устанавливает cost на порту для исходящих маршрутов

rip metricout 

rip poison-reverse

rip split horizon

Ограничение распространения маршрутной информации

int g0/0/0

undo rip output

undo rip input

интерфейс не передает маршрутную информацию, но принимает и заносит в routing table маршруты

rip 1

silent int g0/0/0 — 

Authentification

int g0/0/0

rip authentification-mode simple ….

int g0/0/1

rip authentification-mode md5 usual ….

display

display rip interface verbose

display rip 1 neighbor

OSPF

можно и без указания id. id учитывается при выборах DR, выбирается по наибольшему адресу

ospf 1 router-id 1.1.1.1 

area 0

network ip address wildcard-mask

меняем расчет метрики

ospf 1

bandwidth-reference 10000

меняем cost, таймеры, dr-priority 

int g0/0/0

ospf cost 20

ospf timer hello …

ospf timer dead …

ospf dr-priority …

Authentification OSPF

Simple authentication:

ospf authentication-mode { simple [ [ plain ] | cipher ] | null } 

Cryptographic authentication:

ospf authentication-mode {md5 | hmac-md5 } [ key-id { plain | [ cipher ] } ].

Выключаем OSPF на порту (restrict OSPF operation)

ospf 1

silent-int g0/0/0

Объявление маршрута последней надежды через OSPF

ip route-static 0.0.0.0 0.0.0.0 loopback 0

ospf 1

default-route-advertise

display

disp ospf peer (показывает очень полезную информацию: area, интерфейс и адрес интерфейса, статус соседства, рутер id, master or slave)

disp ospf peer brief

disp ospf 1 int g0/0/0

VRRP

На ip интерфейсе

vrrp vrid 20 virtual-ip 10.74.10.17

vrrp vrid 20 priority 50

Интерфейс с наибольшим значением priority выбирается в качестве Master (default priority 100).

Установка задержки обратного переключению с backup на master

vrrp vrid 1 preempt-mode timer delay 20

При падении интерфейса
GigabitEthernet1/0/0 vrrp приоритет интерфейса g0/0/0 уменьшается на 40

int g0/0/0

vrrp vrid 1 track interface GigabitEthernet1/0/0 reduced 40

VRP Basic and Operation, file system

Работа с файловой системой

Для создания директории

mkdir

Для удаления директории

rmdir

Для удаления и переименование файла

delete

rename

Для удаления файла без возможности восстановления

delete /unreserved

Для восстановления файла

undelete

Для очистки «корзины»

reset recycle-bin

Удаление файла с конфигурацией

delete

Сброс сохранненой конфигурации

reset saved-configuration

Узнать версию софта

display version

display device slot

Работа с ftp

Подключиться по ftp

ftp x.x.x.x

скачать файл

get example.zip

Подключиться по tftp

tftp x.x.x.x get example.zip

Указываем файл startup config

startup system-software example.zip

HDLC

int s2/0/0

link-protocol hdlc

ip address x x x x xx

привязываем адрес loopback

ip unnambered int loopback 0

PPP

Настройка ppp c authentication-mode pap

R1

sysname BRAS

R2

sysname pap_client

Настройка ppp c authentication-mode chap

R1

sysname BRAS

link-protocol ppp

ppp authentication-mode chap

R2

sysname chap_client

int s1/0/0

PPPoE

display pppoe-server session all

sysname BRAS

int dialer 1

display nat server

diplay nat outbound 

diplay nat address-group 1


DHCP

interface pool configuration

dhcp enable

int g0/0/0

dhcp select interface

dhcp server dns-list x.x.x.x

dhcp server excluded-ip-address x.x.x.x

dhcp server lease day x

global pool configuration

dhcp enable

ip pool pool1

network x.x.x.x mask xx

gateway-list x.x.x.x

lease day x

int g0/0/1

dhcp select global

dhcp relay

sysname dhcp server

dhcp enable

ip pool pool1

gateway-list 192.168.1.1

network 192.168.1.0 mask 255.255.255.0

interface GigabitEthernet0/0/0

ip address 10.10.10.1 255.255.255.252

dhcp select global

sysname dhcp relay

dhcp enable

dhcp server group 123

dhcp-server 10.10.10.1 0

interface GigabitEthernet0/0/1

ip address 192.168.1.1 255.255.255.0

dhcp select relay

dhcp relay server-select 123

ACL

basic

acl 2000

rule deny source x.x.x.x wildcard mask

rule permit source x.x.x.x wildcard mask

int g0/0/0

traffic-filter outbound acl 2000

advanced

acl 3000

rule deny tcp source x.x.x.x wildcard mask destination x.x.x.x wildcard mask destination-port eq 21

rule permit source x.x.x.x wildcard mask

int g0/0/0

traffic-filter inbound acl 3000

acl aplication nat

nat address-group 1 x.x.x.x y.y.y.y

acl 2000

rule permit source z.z.z.z wildcard mask

int g0/0/0

nat outbound 2000 address-group 1

AAA

настраиваем способ аутентификации

user-interface vty 0 4

authentication-mode aaa

aaa

создаем схему авторизации

authorization-scheme auth1 

схема без сервера: radius…

authorization-mode local 

создаем схему аутентификации

authentication-scheme auth2

схема без сервера: radius,diametr…

authentication-mode local 

создаем домен и привязываем схемы аутентификации и авторизации

domain huawei

authentication-scheme auth2

authorization-scheme auth1

создаем пользователя в домене и указываем достпные сервисы и привилегии

local-user [email protected] password cipher qwerty

local-user [email protected] service-type telnet

Если оставить только telnet, то по консольному кабелю не будет доступа в случае аутентификации по AAA

user-int con 0

authentication aaa

local-user [email protected] privilege level 0

display domain name huawei

Команды для просмотра информации

display current-configuration — просмотр конфигурации коммутатора. Вывод команды может занимать много строк.

display current-configuration interface ethernet0/0/8 позволяет отобразить текущую конфигурацию для определенного интерфейса, например

SW1-Q2326> display current-configuration interface  Ethernet 0/0/8
#
interface Ethernet0/0/8
 loopback-detect enable
 loopback-detect action shutdown
 stp edged-port enable
 traffic-filter inbound acl 1 rule 10
 traffic-filter inbound acl 2 rule 20
 traffic-filter inbound acl 3 rule 30
 undo ntdp enable
 undo ndp enable
 undo lldp enable
 port-isolate enable group 10
#
return

display interface — просмотр состояния порта

Больше про Хуавей:  Что означают значки на вверху дисплея Samsung гелакси с6: молния, символы, обозначения |

Если в команде не был указан конкретный интерфейс, то команда отобразит информацию обо всех интерфейсах на коммутаторе.

Просмотр информации абонентского интерфейса

SW1-Q2326> display interface Ethernet0/0/2
Ethernet0/0/2 current state : UP
Line protocol current state : UP
Description:HUAWEI, Quidway Series, Ethernet0/0/2 Interface
Switch Port, PVID :   10, TPID : 8100(Hex), 
The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, 
Hardware address is 0025-9e0e-e3c8
Port Mode: COMMON COPPER
Speed :  100,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 64200 bits/sec, 46 packets/sec
Last 300 seconds output rate 167936 bits/sec, 60 packets/sec
Input peak rate 6230872 bits/sec, Record time: 2021-05-22 12:09:21
Output peak rate 82646216 bits/sec, Record time: 2021-05-20 22:28:51
Input:  104198 packets, 36893522 bytes
Unicast        :    104192, Multicast          :        0
Broadcast      :         6, Jumbo              :        0
CRC            :         0, Giants             :        0
Jabbers        :         0, Fragments          :        0
Runts          :         0, DropEvents         :        0
Alignments     :         0, Symbols            :        0
Ignoreds       :         0, Frames             :        0
Discard        :         0, Total Error        :        0
Output:  2351712 packets, 1668837078 bytes
Unicast        :   2140589, Multicast          :   166992
Broadcast      :     44131, Jumbo              :        0
Collisions     :         0, Deferreds          :        0
Late Collisions:         0, ExcessiveCollisions:        0
Buffers Purged :         0  Discard        :            0, 
Total Error    :         0
    Input bandwidth utilization threshold : 100.00%
    Output bandwidth utilization threshold: 100.00%
    Input bandwidth utilization  : 0.06%
    Output bandwidth utilization : 0.17%

В домовых сетях для связи между коммутаторами используются гигабитные порты. Просмотр информации UPLINK интерфейса.

SW1-Q2326> display interface GigabitEthernet 0/0/1
GigabitEthernet0/0/1 current state : UP
Line protocol current state : UP
Description:HUAWEI, Quidway Series, GigabitEthernet0/0/1 Interface
Switch Port, PVID :    10, TPID : 8100(Hex), 
The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, 
Hardware address is 4cb1-6c6d-f0e2
Port Mode: COMBO AUTO
Current Work Mode: COPPER
Speed : 1000,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 24997688 bits/sec, 2342 packets/sec
Last 300 seconds output rate 1229104 bits/sec, 579 packets/sec
Input peak rate 336254096 bits/sec, Record time: 2021-07-21 03:46:12
Output peak rate 222242920 bits/sec, Record time: 2021-09-18 02:36:47
Input:  10903526547 packets, 14024800132234 bytes
Unicast    :  3191030272, Multicast          :  7711769187
Broadcast  :      727088, Jumbo              :           0
CRC        :           0, Giants             :           0
Jabbers    :           0, Fragments          :           0
Runts      :           0, DropEvents         :           0
Alignments :           0, Symbols            :           0
Ignoreds   :           0, Frames             :           0
Discard    :           0, Total Error        :           0
Output:  2021739656 packets, 1111756329252 bytes
Unicast    :  2021859007, Multicast          :     1743883
Broadcast  :     1136766, Jumbo              :           0
Collisions :           0, Deferreds          :           0
Late Collisions:       0, ExcessiveCollisions:           0
Buffers Purged :       0
Discard    :           0, Total Error        :           0
    Input bandwidth utilization threshold : 100.00%
    Output bandwidth utilization threshold: 100.00%
    Input bandwidth utilization  : 2.50%
    Output bandwidth utilization : 0.12%

display mac-address — просмотр мак-адреса

SW1-Q2326>display mac-address
-------------------------------------------------------
MAC Address    VLAN/VSI     Learned-From        Type
-------------------------------------------------------
1caf-f762-b607 10/-        Eth0/0/2            dynamic
2c39-96a8-60f5 10/-        Eth0/0/24           dynamic
2c39-96a8-60f6 10/-        Eth0/0/24           dynamic
2c39-96d9-6d4e 10/-        GE0/0/2             dynamic
2c39-96d9-6d4f 10/-        GE0/0/2             dynamic
348a-ae19-aa1b 10/-        GE0/0/2             dynamic
348a-ae19-aa1c 10/-        GE0/0/2             dynamic
e894-f6b7-a00d 10/-        Eth0/0/3            dynamic
0025-9ed4-64ca 20/-        GE0/0/1             dynamic
286e-d455-d7b0 20/-        GE0/0/2             dynamic
-------------------------------------------------------
Total items displayed = 10

При указании номера интерфейса команда покажет информацию о мак-адресах на конкретно заданном интерфейсе, например:

	
SW1-Q2326> display mac-address dynamic Ethernet0/0/2
------------------------------------------------------------------
MAC Address    VLAN/VSI            Learned-From           Type
------------------------------------------------------------------
1caf-f762-b607 10/-                   Eth0/0/2            dynamic

------------------------------------------------------------------
Total items displayed = 1

Отбор данных по заданному признаку осуществляется с помощью include. Например, нам необходимо найти порт на коммутаторе, зная только мак-адрес оборудования. В этом случае нам поможет следующая команда:

SW1-Q2326> display mac-address dynamic | include 1caf-f762-b607
MAC address table of slot 0:
------------------------------------------------------------------
MAC Address    VLAN/   PEVLAN CEVLAN   Port      Type  LSP/LSR-ID
               VSI/SI                                              
------------------------------------------------------------------
1caf-f762-b607  10        -    -     Eth0/0/2  dynamic      -

------------------------------------------------------------------
Total matching items on slot 0 displayed = 10

Результат отработки команды показывает, что нужный нам мак-адрес 1caf-f762-b607 находится на 2 порту коммутатора.

display interface description — просмотр описания портов коммутатора.

SW1-Q2326> display interface description
Interface       Description
Ethernet0/0/1   HUAWEI, Quidway Series, Ethernet0/0/1 Interface
Ethernet0/0/2   HUAWEI, Quidway Series, Ethernet0/0/2 Interface
Ethernet0/0/3   HUAWEI, Quidway Series, Ethernet0/0/3 Interface
Ethernet0/0/4   HUAWEI, Quidway Series, Ethernet0/0/4 Interface
Ethernet0/0/5   HUAWEI, Quidway Series, Ethernet0/0/5 Interface
Ethernet0/0/6   HUAWEI, Quidway Series, Ethernet0/0/6 Interface
Ethernet0/0/7   HUAWEI, Quidway Series, Ethernet0/0/7 Interface
Ethernet0/0/8   HUAWEI, Quidway Series, Ethernet0/0/8 Interface
GigabitEthernet0/0/1  HUAWEI, Quidway Series, GigabitEthernet0/0/1                       
NULL0           HUAWEI, Quidway Series, NULL0 Interface
Vlanif10        HUAWEI, Quidway Series, Vlanif998 Interface

https://www.youtube.com/watch?v=_lWFT6fqxmI

Описание (description) можно изменить на свое. Это очень важно и позволяет прописать необходимую служебную информацию, например

Обновляем мастер коммутатор

Последовательность действий целом такая же.

Процедура коротко.

<sw21>startup system-software flash:/CE6810LI-V200R005C10SPC800.cc
<sw21>startup patch flash:/CE6810LI-V200R005SPH008.PAT all 
<sw21>dis startup
<sw21>reboot 

Процедура подробнее.

Процедура подробнее.

1. Задаем версию софта с которой надо загружаться.

<sw21>dir flash:/
Directory of flash:/

  Idx  Attr     Size(Byte)  Date        Time       FileName                     
    0  dr-x              -  Sep 19 2022 13:04:34   $_checkpoint                 
    1  dr-x              -  Aug 22 2022 12:12:27   $_install_mod                
    2  dr-x              -  Nov 03 2022 17:55:23   $_license                    
    3  dr-x              -  Jun 14 2022 23:30:32   $_security_info              
    4  dr-x              -  Sep 19 2022 13:03:45   $_system                     
    5  -rw-    128,772,300  Jan 04 2022 13:21:49   CE6810LI-V200R002C50SPC800.cc
    6  -rw-      1,339,283  Nov 03 2022 17:57:13   CE6810LI-V200R002SPH016.PAT  
    7  -rw-      4,206,539  Sep 19 2022 12:50:14   CE6810LI-V200R002SPH022.PAT  
    8  -rw-    135,653,156  Sep 19 2022 13:35:20   CE6810LI-V200R005C10SPC800.cc
    9  -rw-      2,826,131  Sep 19 2022 13:36:08   CE6810LI-V200R005SPH008.PAT  
   10  drwx              -  Nov 03 2022 17:52:09   POST                         
   11  -rw-             45  Sep 11 2022 23:29:44   SysResTemplate.ini           
   12  -rw-             97  Nov 03 2022 17:52:12   collect_diag_info.bat        
   13  -rw-         22,691  Sep 19 2022 13:00:35   device.sys                   
   14  drwx              -  Sep 19 2022 09:30:09   logfile                      
   15  -rw-          2,150  Sep 19 2022 13:00:35   vrpcfg.zip                   
   16  -rw-          5,914  Mar 04 2022 20:00:29   ztp_20220304165135.log       
   17  -rw-         13,961  Mar 04 2022 19:58:59   ztp_20220304165135.log.1     
   18  -rw-            824  Mar 04 2022 19:54:19   ztp_20220304165135.log.2     

269,168 KB total (11,080 KB free)

<sw21>startup system-software flash:/CE6810LI-V200R005C10SPC800.cc ?
  all          For all boards
  slave-board  For the slave control board
  slot         Specify the slot ID
  |            Matching output
  >            Redirect the output to a file
  >>           Redirect the output to a file in append mode
  <cr>         

<sw21>startup system-software flash:/CE6810LI-V200R005C10SPC800.cc
Info: Operating, please wait for a moment..............................................done.
Info: Succeeded in setting the next startup software in slot 1.

<sw21>startup patch flash:/CE6810LI-V200R005SPH008.PAT ?
  all  All the slots

<sw21>startup patch flash:/CE6810LI-V200R005SPH008.PAT all 
Info: Operating, please wait for a moment...........done.
Info: Succeeded in setting startup the patch.

<sw21>dis startup
MainBoard:
  Configured startup system software:        flash:/CE6810LI-V200R002C50SPC800.cc
  Startup system software:                   flash:/CE6810LI-V200R002C50SPC800.cc
  Next startup system software:              flash:/CE6810LI-V200R005C10SPC800.cc
  Startup saved-configuration file:          flash:/vrpcfg.zip
  Next startup saved-configuration file:     flash:/vrpcfg.zip
  Startup paf file:                          default
  Next startup paf file:                     default
  Startup patch package:                     flash:/CE6810LI-V200R002SPH022.PAT
  Next startup patch package:                flash:/CE6810LI-V200R005SPH008.PAT

2. Перегружаем мастер коммутатор.

Сразу после того, как sw21 начал перегружаться, ушел mismatch на sw22.

<sw22>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : Lost
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 120
  Address        : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : PEERLINKDOWN 
  System ID      : 4857-02cc-aea1 
  SysName        : sw22 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI
<sw22>

Процедура перезагрузки.

reboot 
slot 1:
Next startup system software: flash:/CE6810LI-V200R005C10SPC800.cc
Next startup saved-configuration file: flash:/vrpcfg.zip
Next startup paf file: default
Next startup patch package: flash:/CE6810LI-V200R005SPH008.PAT
Warning: The system will reboot. Continue? [Y/N]:y


После ребута sw21 на sw22 мисматч ушел

<sw22>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : Lost
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 120
  Address        : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : PEERLINKDOWN 
  System ID      : 4857-02cc-aea1 
  SysName        : sw22 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI
<sw22>

Warning: The system will reboot. Continue? [Y/N]:y
Sep 19 2022 14:01:52 03:00 sw21 %SYSTEM/4/SYS_RELOAD_ACTION(l):CID=0x80cc000d;The board was reboot. (ReloadIndex=257, ReloadImage=2, ReloadCfg=14, ReloadReason=, ReloadTime=0000-00-00 00:00:00, ReloadAction=3, ReloadPaf=0, ReloadLicense=0, ReloadPatch=3).

#30/active/hwLocalFaultAlarm/Minor/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x081320c6/CID=0x80fc0101:The local fault alarm has occurred. (IfIndex=55, IfName=40GE1/0/3)

#31/active/hwRemoteFaultAlarm/Minor/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x081320c7/CID=0x80fc0101:The remote fault alarm has occurred. (IfIndex=55, IfName=40GE1/0/3)

#32/active/hwLocalFaultAlarm/Minor/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x081320c6/CID=0x80fc0101:The local fault alarm has occurred. (IfIndex=56, IfName=40GE1/0/4)

#33/active/hwRemoteFaultAlarm/Minor/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x081320c7/CID=0x80fc0101:The remote fault alarm has occurred. (IfIndex=56, IfName=40GE1/0/4)

#34/active/linkDown/Major/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x08520003/CID=0x807a0404:The interface status changes. (ifName=Eth-Trunk16, AdminStatus=UP, OperStatus=DOWN, Reason=The conditions for the activation of the interface are not met, mainIfname=Eth-Trunk16)

#35/active/linkDown/Major/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x08520003/CID=0x807a0404:The interface status changes. (ifName=10GE1/0/16, AdminStatus=UP, OperStatus=DOWN, Reason=Interface physical link is down, mainIfname=Eth-Trunk16)

#36/active/linkDown/Major/occurredTime:2022-09-19 14:01:54 03:00/-/-/alarmID:0x08520003/CID=0x807a0404:The interface status changes. (ifName=40GE1/0/3, AdminStatus=UP, OperStatus=DOWN, R

*************************************************************
*  Copyright (C)  Huawei Technologies Co., Ltd.  *
*************************************************************

CloudEngine BIOS Version: 433  (Oct 11 2022 - 20:19:17)
Board Name ..................................... CE6810-48S4Q-LI
SDRAM Memory Initializing ...................... BEGIN
SDRAM Memory Size .............................. 2 Gbytes
SDRAM Memory Initializing ...................... DONE 

Press CTRL T for full memory test .............. skip


Starting ... 

Press CTRL B to enter BIOS menu or CTRL E to boot DFX: 0 
Boot Disk: flash
Startup File: CE6810LI-V200R005C10SPC800.cc
Try Times: 1
             
Check system software ........................................ DONE
Check APPDB .................................................. DONE
Set next bootfile ............................................ DONE
Load system software ......................................... DONE
Create file system ........................................... DONE
 
Now starting VRP ........

Configured switch mode ....................................... AUTO-NEGOTIATION
Current switch mode .......................................... STACK
Press CTRL Y to modify the switch mode ....................... skip

Initializing stack ........................................... DONE
Stack member ID .............................................. 1
Stack domain ID .............................................. INVALID
Stack priority ............................................... 100
Default MAC .................................................. 48-57-02-cc-ae-f0
Competing with other devices in the stack .................... DONE
Stack role ................................................... MASTER

User interface con0 is available


Please Press ENTER.


Password:
Info: The max number of VTY users is 5, the number of current VTY users online is 0, and total number of terminal users online is 1.
      The current login time is 2022-09-19 14:07:03 03:00.

3. Момент когда поднимаются PL порты.

Больше про Хуавей:  HUAWEI Routers - HUAWEI Global

После того, как подялись PL, все заработало.
Mismatch ушел.

<sw21>dis dfs-group 1
  Dfs-Group ID      : 1
  Priority          : 150
  UDP Port          : -
  Address           : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  System ID         : 4857-02cc-aef1 
  SysName           : sw21
  Up-delay/Interval : 240/0
  Switch-delay      : 0

  Configuration consistency check: --

<sw21>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : Lost
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 150
  Address        : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : PEERLINKDOWN 
  System ID      : 4857-02cc-aef1 
  SysName        : sw21 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI

<sw21>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : Lost
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 150
  Address        : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : PEERLINKDOWN 
  System ID      : 4857-02cc-aef1 
  SysName        : sw21 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI

<sw21>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : Lost
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 150
  Address        : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : TIMEOUT 
  System ID      : 4857-02cc-aef1 
  SysName        : sw21 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI

<sw21>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : OK
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 150
  Address        : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : - 
  System ID      : 4857-02cc-aef1 
  SysName        : sw21 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI
Node 2                            
  Dfs-Group ID   : 1
  Priority       : 120
  Address        : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  State          : Backup
  Causation      : - 
  System ID      : 4857-02cc-aea1 
  SysName        : sw22 
  Version        : V200R005C10SPC800 
  Device Type    : CE6810LI
<sw21>

Версия софтра на sw21.

<sw21>dis version 
Huawei Versatile Routing Platform Software
VRP (R) software, Version 8.180 (CE6810LI V200R005C10SPC800)
Copyright (C) 2022-2022 Huawei Technologies Co., Ltd.
HUAWEI CE6810-48S4Q-LI uptime is 0 day, 0 hour, 5 minutes 
Patch Version: V200R005SPH008

CE6810-48S4Q-LI(Master) 1 : uptime is  0 day, 0 hour, 4 minutes
        StartupTime 2022/09/19   14:05:34 03:00
Memory    Size    : 2048 M bytes
Flash     Size    : 512 M bytes
CE6810-48S4Q-LI version information                               
1. PCB    Version : CEM48S4QP04    VER A
2. MAB    Version : 1
3. Board  Type    : CE6810-48S4Q-LI
4. CPLD1  Version : 101
5. CPLD2  Version : 101
6. BIOS   Version : 433

<sw21>dis patch-information 
Patch Package Name    :flash:/CE6810LI-V200R005SPH008.PAT
Patch Package Version :V200R005SPH008
Patch Package State   :Running   
Patch Package Run Time:2022-09-19 14:03:42 03:00

Через 4 минуты поднялись MLAG порты на sw21 и все заработало в штатном режиме.

<sw21>dis dfs-group 1 node 1 m-lag 
* - Local node

M-Lag ID          : 16
Interface         : Eth-Trunk 16
Port State        : Down
Status            : inactive(*)-active
Member Port Role  : Invalid(*)-Master

<sw21>dis dfs-group 1 node 2 m-lag 
* - Local node

M-Lag ID          : 16
Interface         : Eth-Trunk 16
Port State        : Up
Status            : active-inactive(*)
Member Port Role  : Master-Invalid(*)
<sw21>

<sw21>dis dfs-group 1 node 1 m-lag 
* - Local node

M-Lag ID          : 16
Interface         : Eth-Trunk 16
Port State        : Up
Status            : active(*)-active
Member Port Role  : Backup(*)-Master

<sw21>dis dfs-group 1 node 2 m-lag  
* - Local node

M-Lag ID          : 16
Interface         : Eth-Trunk 16
Port State        : Up
Status            : active-active(*)
Member Port Role  : Master-Backup(*)

В выводе появилось новое поле “Member Port Role”.
Распределиение ролей в не соответствет заданным приоритетам, все наоборот. С этим надо будет еще разобраться.

Все, на этом обновление закончено.


Обновляем слейв коммутатор

У коммутаторов ce6810LI только одна загрузочная область.

<sw21>dis startup slot ?
  <1>  The available slot

<sw21>dis startup slot 1
MainBoard:
  Configured startup system software:        flash:/CE6810LI-V200R005C10SPC800.cc
  Startup system software:                   flash:/CE6810LI-V200R005C10SPC800.cc
  Next startup system software:              flash:/CE6810LI-V200R005C10SPC800.cc
  Startup saved-configuration file:          flash:/vrpcfg.zip
  Next startup saved-configuration file:     flash:/vrpcfg.zip
  Startup paf file:                          default
  Next startup paf file:                     default
  Startup patch package:                     flash:/CE6810LI-V200R005SPH008.PAT
  Next startup patch package:                flash:/CE6810LI-V200R005SPH008.PAT
<sw21>

Поэтому смысл обновления заключается в том, что бы указать коммутатору с какой версии софта и с каким патчем ему нужно грузиться (из единственной загрузочной обласли) в следующий раз и перезагрузить коммутатор.

Когда обновится слейв коммутатор, MLAG-пара продолжит нормально работать.
Единственное, что коммутатор будет в выводе “dis dfs-group 1 m-lag” явным образом сообщать о том, что версии софта на нодах разные.
Информации о том, сколько коммутаторы могут проработать в таком состоянии не нашел, но лучше не затягивать.

Mellanox в таком состоянии будет работать в течении часа, а потом положит MLAG порты.

Так же, в версии софта V200R005, увеличилось дефолтное значение MLAG таймера “up-delay” — c 120 до 240 секунд.
Т.е. после того как коммутатор загрузится, MLAG порты еще 4 минуты будут в дауне.

Процедура коротко.

<sw22>startup system-software flash:/CE6810LI-V200R005C10SPC800.cc
<sw22>startup patch flash:/CE6810LI-V200R005SPH008.PAT all
<sw22>dis startup
<sw22>reboot

Процедура подробнее.

Процедура подробнее.

1. Задаем версию софта с которой надо загружаться.

<sw22>startup system-software ?
  STRING<5-127>  [drive][path][file name]
  flash:         Device name

<sw22>startup system-software flash:/?  
  flash:/../                              flash:/./
  flash:/CE6810LI-V200R002C50SPC800.cc    flash:/CE6810LI-V200R002SPH022.PAT
  flash:/CE6810LI-V200R005C10SPC800.cc    flash:/CE6810LI-V200R005SPH008.PAT
  flash:/SysResTemplate.ini               flash:/collect_diag_info.bat
  flash:/device.sys                       flash:/vrpcfg.zip
  flash:/ztp_20220304170526.log           flash:/ztp_20220304170526.log.1
  flash:/ztp_20220304170526.log.2         flash:/ztp_20220304170526.log.3
  flash:/ztp_20220304170526.log.4

<sw22>startup system-software flash:/CE6810LI-V200R005C10SPC800.cc
Info: Operating, please wait for a moment............................................done.
Info: Succeeded in setting the next startup software in slot 1.

<sw22>startup patch flash:/CE6810LI-V200R005SPH008.PAT ?
  all  All the slots

<sw22>startup patch flash:/CE6810LI-V200R005SPH008.PAT all ?
  |     Matching output
  >     Redirect the output to a file
  >>    Redirect the output to a file in append mode
  <cr>  

<sw22>startup patch flash:/CE6810LI-V200R005SPH008.PAT all 
Info: Operating, please wait for a moment...........done.
Info: Succeeded in setting startup the patch.

<sw22>dis startup 
MainBoard:
  Configured startup system software:        flash:/CE6810LI-V200R002C50SPC800.cc
  Startup system software:                   flash:/CE6810LI-V200R002C50SPC800.cc
  Next startup system software:              flash:/CE6810LI-V200R005C10SPC800.cc
  Startup saved-configuration file:          flash:/vrpcfg.zip
  Next startup saved-configuration file:     flash:/vrpcfg.zip
  Startup paf file:                          default
  Next startup paf file:                     default
  Startup patch package:                     flash:/CE6810LI-V200R002SPH022.PAT
  Next startup patch package:                flash:/CE6810LI-V200R005SPH008.PAT

2. Перегружаем слейв коммутатор.

<sw22>reboot 
slot 1:
Next startup system software: flash:/CE6810LI-V200R005C10SPC800.cc
Next startup saved-configuration file: flash:/vrpcfg.zip
Next startup paf file: default
Next startup patch package: flash:/CE6810LI-V200R005SPH008.PAT
Warning: The system will reboot. Continue? [Y/N]:y

Sep 19 2022 13:46:00 03:00 sw22 %SYSTEM/4/SYS_RELOAD_ACTION(l):CID=0x80cc000d;The board was reboot. (ReloadIndex=257, ReloadImage=2, ReloadCfg=83, ReloadReason=, ReloadTime=0000-00-00 00:00:00, ReloadAction=3, ReloadPaf=0, ReloadLicense=0, ReloadPatch=2).

#11/active/linkDown/Major/occurredTime:2022-09-19 13:46:02 03:00/-/-/alarmID:0x08520003/CID=0x807a0404:The interface status changes. (ifName=Eth-Trunk16, AdminStatus=UP, OperStatus=DOWN, Reason=The conditions for the activation of the interface are not met, mainIfname=Eth-Trunk16)

#12/active/linkDown/Major/occurredTime:2022-09-19 13:46:02 03:00/-/-/alarmID:0x08520003/CID=0x807a0404:The interface status changes. (ifName=10GE1/0/16, AdminStatus=UP, OperStatus=DOWN, Reason=Interface physical link is down, mainIfname=Eth-Trunk16)

#13/active/hwLacpNegotiateFailed/Major/occurredTime:2022-09-19 13:46:02 03:00/-/-/alarmID:0x09360000/CID=0x807a0404:The member of LAG negotiation failed. (TrunkIndex=2, PortIfIndex=20, TrunkId=16, TrunkName=Eth-Trunk16, PortName=10GE1/0/16, Reason=A link fault occurred or negotiation information synchronization failed.)

Sep 19 2022 13:46:03 03:00 sw22 %LACP/4/LACP_STATE_DOWN(l):CID=0x80480432;The LACP state is down. (PortName=10GE1/0/16, TrunkName=Eth-Trunk16, LastReceivePacketTime=[2022-09-19 13:45:52:225 03:00], Reason=The interface went down physically or flapped to down. Please check the interface's status, duplex mode, bandwidth, and so on.)

#14/active/hwLocalFaultAlarm/Minor/occurredTime:2022-09-19 13:46:03 03:00/-/-/alarmID:0x081320c6/CID=0x80fc0101:The local fault alarm has occurred. (IfIndex=55, IfName=40GE1/0/3)

Sep 19 2022 13:46:02 03:00 sw22 %IFNET/2/linkDown_active(l):CID=0x807a0404-alarmID=0x08520003;The interface status changes. (ifName=Eth-Trunk16, AdminStatus=UP, OperStatus=DOWN, Reason=The conditions for the activation of the interface are not met, mainIfname=Eth-Trunk16)

Sep 19 2022 13:46:02 03:00 sw22 %IFNET/2/linkDown_active(l):CID=0x807a0404-alarmID=0x08520003;The interface status changes. (ifName=10GE1/0/16, AdminStatus=UP, Op

*************************************************************
*  Copyright (C) <2022-2022> Huawei Technologies Co., Ltd.  *
*************************************************************

CloudEngine BIOS Version: 433  (Oct 11 2022 - 20:19:17)
Board Name ..................................... CE6810-48S4Q-LI
SDRAM Memory Initializing ...................... BEGIN
SDRAM Memory Size .............................. 2 Gbytes
SDRAM Memory Initializing ...................... DONE 

Press CTRL T for full memory test .............. skip


Starting ... 

Press CTRL B to enter BIOS menu or CTRL E to boot DFX: 0 
Boot Disk: flash
Startup File: CE6810LI-V200R005C10SPC800.cc
Try Times: 1
             
Check system software ........................................ DONE
Check APPDB .................................................. DONE
Set next bootfile ............................................ DONE
Load system software ......................................... DONE
Create file system ........................................... DONE
 
Now starting VRP ........

Configured switch mode ....................................... AUTO-NEGOTIATION
Current switch mode .......................................... STACK
Press CTRL Y to modify the switch mode ....................... skip

Initializing stack ........................................... DONE
Stack member ID .............................................. 1
Stack domain ID .............................................. INVALID
Stack priority ............................................... 100
Default MAC .................................................. 48-57-02-cc-ae-a0
Competing with other devices in the stack .................... DONE
Stack role ................................................... MASTER

Stack role ................................................... MASTER


User interface con0 is available


Please Press ENTER.


Password:
Info: The max number of VTY users is 5, the number of current VTY users online is 0, and total number of terminal users online is 1.
      The current login time is 2022-09-19 13:51:14 03:00.
<sw22>


<sw22>dis current-configuration 
Error: The system is busy in building configuration. Please wait for a moment...

3. Проверяем версию и состояние MLAG.

Больше про Хуавей:  Как поменять страну в телефоне на Андроид - подробная инструкция

DAD все хорошо, PeerLink поднялись, роли коммутаторов распределились правильно, видим mismatch в версиях софта.
Трафик при этом ходит.

<sw22>dis version 
Huawei Versatile Routing Platform Software
VRP (R) software, Version 8.180 (CE6810LI V200R005C10SPC800)
Copyright (C) 2022-2022 Huawei Technologies Co., Ltd.
HUAWEI CE6810-48S4Q-LI uptime is 0 day, 0 hour, 3 minutes 
Patch Version: V200R005SPH008

CE6810-48S4Q-LI(Master) 1 : uptime is  0 day, 0 hour, 1 minutes
        StartupTime 2022/09/19   13:49:39 03:00
Memory    Size    : 2048 M bytes
Flash     Size    : 512 M bytes
CE6810-48S4Q-LI version information                               
1. PCB    Version : CEM48S4QP04    VER A
2. MAB    Version : 1
3. Board  Type    : CE6810-48S4Q-LI
4. CPLD1  Version : 101
5. CPLD2  Version : 101
6. BIOS   Version : 433

<sw22>dis patch-information
Patch Package Name    :flash:/CE6810LI-V200R005SPH008.PAT
Patch Package Version :V200R005SPH008
Patch Package State   :Running   
Patch Package Run Time:2022-09-19 13:48:00 03:00
<sw22>

<sw22>dis dfs-group 1
  Dfs-Group ID      : 1
  Priority          : 120
  UDP Port          : -
  Address           : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  System ID         : 4857-02cc-aea1 
  SysName           : sw22
  Up-delay/Interval : 240/0
  Switch-delay      : 0

<sw22>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : OK
Node 2 *                            
  Dfs-Group ID   : 1
  Priority       : 120
  Address        : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  State          : Backup
  Causation      : - 
  System ID      : 4857-02cc-aea1 
  SysName        : sw22 
  Version        : V200R005C10SPC800(mismatch) 
  Device Type    : CE6810LI
Node 1                            
  Dfs-Group ID   : 1
  Priority       : 150
  Address        : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : - 
  System ID      : 4857-02cc-aef1 
  SysName        : sw21 
  Version        : V200R002C50SPC800(mismatch) 
  Device Type    : CE6810LI
<sw22>

<sw22>dis dfs-group 1 node 1 m-lag 
* - Local node

M-Lag ID          : 16
Interface         : Eth-Trunk 16
Port State        : Up
Status            : active-inactive(*)
Member Port Role  : Master-Invalid(*)

<sw22>dis dfs-group 1 node 2 m-lag 
* - Local node

M-Lag ID          : 16
Interface         : Eth-Trunk 16
Port State        : Down
Status            : inactive(*)-active
Member Port Role  : Invalid(*)-Master

<sw22>dis dfs-group 1
  Dfs-Group ID      : 1
  Priority          : 120
  UDP Port          : -
  Address           : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  System ID         : 4857-02cc-aea1 
  SysName           : sw22
  Up-delay/Interval : 240/0
  Switch-delay      : 0

  Configuration consistency check: --

Патчим текущую версию софта

Процедура коротко.

Выполняем на обоих коммутаторах.
Ниже показан способ подключения к серверу из документации, но мне больше нравится из предыдущего пункта, когда говорим принимать ключ.

<sw22>system-view
[~sw22]ssh client first-time enable 
[*sw22]commit 
[~sw22]sftp 10.x.x.x -vpn-instance VRF-DAD-1 
sftp-client>cd /opt/soft/huawei
sftp-client>get CE6810LI-V200R002SPH022.PAT
sftp-client>bye     
[~sw22]quit
<sw22>patch load flash:/CE6810LI-V200R002SPH022.PAT all run 
<sw22>dis patch-information

После применения патчка на первом коммутаторе состояние MLAG (dis dfs-group 1 m-lag) никак не поменялось, все продолжило работать.
Для порядку можно перегрузить коммутаторы.

Процедура подробнее.

Процедура подробнее.

1. Закачиваем на коммутатор патч.

<sw22>system-view
[~sw22]ssh client first-time enable 
[*sw22]commit 
[~sw22]sftp 10.x.x.x -vpn-instance VRF-DAD-1 
Trying 10.x.x.x ...
Press CTRL K to abort
Connected to 10.x.x.x ...
The server is not authenticated. Continue to access it? [Y/N]:y
Save the server's public key? [Y/N]:n

Please input the username: 
Enter password: 

sftp-client>?   
Current view commands:
  bye     Quit sftp
  cd      Change remote directory to path
  cdup    Change remote directory to uplevel
  delete  Delete remote files(no more than 10 in one time)
  dir     Display remote directory listing."-a" will only list all files name of
          the directory."-l" will list not only files name, but also other
          information. If path argument is not given, list current directory
  exit    Quit sftp
  get     Download file. Default local file name is the same with remote file
  help    "help all" will print all command names. "help [command name]" will
          print information for specified command
  ls      Display remote directory listing."-a" will only list all files name of
          the directory."-l" will list not only files name, but also other
          information. If path argument is not given, list current directory
  mkdir   Create remote directory
  put     Upload file. Default remote file name is the same with local file
  pwd     Display remote working directory
  quit    Quit sftp
  remove  Delete remote files(no more than 10 in one time)
  rename  Rename remote file
  rmdir   Delete remote directories(no more than 10 in one time)

sftp-client>

sftp-client>cd /opt/soft/huawei
Current directory is: 
/opt/soft/huawei
sftp-client>ls
drwxr-xr-x    3 xxx root         4096 Sep 19 12:21 ..
-rw-r--r--    1 xxx root      4206539 Sep 19 12:21 CE6810LI-V200R002SPH022.PAT
-rw-r--r--    1 xxx root     135653156 Sep 19 12:22 CE6810LI-V200R005C10SPC800.cc
-rw-r--r--    1 xxx root      2826131 Sep 19 12:21 CE6810LI-V200R005SPH008.PAT
drwxr-xr-x    2 xxx root         4096 Sep 19 12:22 .
sftp-client>

sftp-client>get CE6810LI-V200R002SPH022.PAT
Remote file: /opt/soft/huawei/CE6810LI-V200R002SPH022.PAT --->  Local file: CE6810LI-V200R002SPH022.PAT
Downloading the file. Please wait...|
Downloading file successfully ended.
File download is completed in 18 seconds.
sftp-client>
sftp-client>bye     
Bye

[~sw22]quit     
<sw22>dir flash:/
Directory of flash:/

  Idx  Attr     Size(Byte)  Date        Time       FileName                     
    0  dr-x              -  Sep 19 2022 17:30:47   $_checkpoint                 
    1  dr-x              -  Aug 22 2022 09:12:27   $_install_mod                
    2  dr-x              -  Nov 03 2022 14:44:11   $_license                    
    3  dr-x              -  Jun 18 2022 21:31:05   $_security_info              
    4  dr-x              -  Jun 18 2022 21:03:08   $_system                     
    5  -rw-    128,772,300  Jan 04 2022 10:21:49   CE6810LI-V200R002C50SPC800.cc
    6  -rw-      1,339,283  Nov 03 2022 14:45:40   CE6810LI-V200R002SPH016.PAT  
    7  -rw-      4,206,539  Sep 19 2022 17:36:55   CE6810LI-V200R002SPH022.PAT  
    8  drwx              -  Nov 03 2022 14:40:58   POST                         
    9  -rw-             45  Jun 19 2022 17:20:24   SysResTemplate.ini           
   10  -rw-             97  Nov 03 2022 14:41:02   collect_diag_info.bat        
   11  -rw-         22,691  Sep 18 2022 18:24:53   device.sys                   
   12  drwx              -  Sep 19 2022 17:33:17   logfile                      
   13  -rw-          1,837  Sep 18 2022 18:24:53   vrpcfg.zip                   
   14  -rw-          5,914  Jun 04 2022 22:54:02   ztp_20220304170526.log       
   15  -rw-         13,961  Jun 04 2022 22:35:46   ztp_20220304170526.log.1     
   16  -rw-         13,961  Jun 04 2022 22:28:16   ztp_20220304170526.log.2     
   17  -rw-         13,961  Jun 04 2022 22:20:47   ztp_20220304170526.log.3     
   18  -rw-         13,961  Jun 04 2022 22:13:16   ztp_20220304170526.log.4     

269,168 KB total (140,568 KB free)

2. На sw21 смотрим состояние MLAG до применения патча на sw22.

<sw21>dis dfs-group 1 m-lag 
*                : Local node
Heart beat state : OK
Node 1 *                            
  Dfs-Group ID   : 1
  Priority       : 150
  Address        : ip address 10.20.35.141 vpn-instance VRF-DAD-1
  State          : Master
  Causation      : - 
  System ID      : 4857-02cc-aef1 
  SysName        : sw21 
  Version        : V200R002C50SPC800 
  Device Type    : CE6810LI
Node 2                            
  Dfs-Group ID   : 1
  Priority       : 120
  Address        : ip address 10.20.35.142 vpn-instance VRF-DAD-1
  State          : Backup
  Causation      : - 
  System ID      : 4857-02cc-aea1 
  SysName        : sw22 
  Version        : V200R002C50SPC800 
  Device Type    : CE6810LI
<sw21>dis dfs-group 1 no    
<sw21>dis dfs-group 1 node 1 m
<sw21>dis dfs-group 1 node 1 m-lag 
* - Local node

M-Lag ID     : 16
Interface    : Eth-Trunk 16
Port State   : Up
Status       : active(*)-active

<sw21>dis dfs-group 1 node 2 m-lag 
* - Local node

M-Lag ID     : 16
Interface    : Eth-Trunk 16
Port State   : Up
Status       : active-active(*)

3. Применяем патч на sw22.

<sw22>patch load ?
  STRING<5-127>  [drive][path][file name]
  flash:         Device name

<sw22>patch load flash:/?
  flash:/../                              flash:/./
  flash:/CE6810LI-V200R002C50SPC800.cc    flash:/CE6810LI-V200R002SPH016.PAT
  flash:/CE6810LI-V200R002SPH022.PAT      flash:/SysResTemplate.ini
  flash:/collect_diag_info.bat            flash:/device.sys
  flash:/vrpcfg.zip                       flash:/ztp_20220304170526.log
  flash:/ztp_20220304170526.log.1         flash:/ztp_20220304170526.log.2
  flash:/ztp_20220304170526.log.3         flash:/ztp_20220304170526.log.4
<sw22>patch load flash:/CE6810LI-V200R002SPH022.PAT ?
  all  All the slots

<sw22>patch load flash:/CE6810LI-V200R002SPH022.PAT all ?
  active  Activate the patch
  run     Run the patch
  |       Matching output
  >       Redirect the output to a file
  >>      Redirect the output to a file in append mode
  <cr>    

<sw22>patch load flash:/CE6810LI-V200R002SPH022.PAT all ru
<sw22>patch load flash:/CE6810LI-V200R002SPH022.PAT all run ?
  |     Matching output
  >     Redirect the output to a file
  >>    Redirect the output to a file in append mode
  <cr>  

<sw22>patch load flash:/CE6810LI-V200R002SPH022.PAT all run 
Info: Operating, please wait for a moment..............done.
Info: Succeeded in running the patch.

<sw22>dis patch-information
Patch Package Name    :flash:/CE6810LI-V200R002SPH022.PAT
Patch Package Version :V200R002SPH022
Patch Package State   :Running   
Patch Package Run Time:2022-09-19 17:42:47
<sw22>

4. Проверяем состонияние MLAG после применения патчка на sw22.
Состояние не изменилось, все продолжило работать.


1 Звездаслабоватона троечкухорошо!просто отлично! (1 оценок, среднее: 5,00 из 5)
Загрузка...

Расскажите нам ваше мнение:

Ваш адрес email не будет опубликован. Обязательные поля помечены *