Коммутаторы. Коммутаторы для интернета — продукты Huawei

Содержание

Анализ tcp/udp потоков на основе edge intelligence

Edge Intelligence (TAP) реализуется с помощью выделенного чипа на коммутаторе, цель которого – сбор и анализ потоков TCP/UPD, и экспорт результатов анализа в iMaster NCE-FabricInsight (TDA).

Traffic-analysis data exporter (TDE), traffic-analysis processor (TAP), traffic-analysis data analyzer (TDA)
Traffic-analysis data exporter (TDE), traffic-analysis processor (TAP), traffic-analysis data analyzer (TDA)

В отличие от анализа потока TCP, анализ потока UDP выполняется на основе детализации блоков. Edge Intelligence (TAP) при идентификации потока определяет порядковые номера UDP-пакетов. На основе этих номеров пакеты в потоке UDP группируются в несколько блоков.

После получения таблицы потоков UDP, iMaster NCE-FabricInsight вычисляет информацию о потоке (включая количество пакетов, количество байтов и скорость) и качество пересылки (потеря пакетов и задержка) между каждыми двумя соседними устройствами на основе TTL.

Почему не fibre channel

Среди эксплуатантов Fibre Channel нет такого оптимизма. Там до сих пор можно найти много legacy-дизайнов на 8/16G, постепенно появляются проекты на базе 32G, в то время как начало коммерческой реализации 64G запланировано на первые месяцы следующего года. Попробуем сравнить обе сети.

Как было сказано ранее, Fibre Channel значительно проигрывает Ethernet в пропускной способности. Кто-то скажет, что Ethernet – сеть с потерями. Это действительно так, но уже есть целый ряд алгоритмов, которые нивелируют этот недостаток.

Не будем забывать и о том, что, строя сеть Fibre Channel, заказчик попадает в зависимость от одного поставщика, а это неизбежно влечет за собой высокую совокупную стоимость владения инфраструктурой. Она вытекает из стоимости оборудования, сопровождения, а также необходимости держать отдельную команду по эксплуатации.

Открытым остается и вопрос о том, будет ли способен поставщик перестраиваться в соответствии с новыми задачами и вызовами так же быстро и охотно, как производители Ethernet-оборудования.

Пойдем глубже. Итак, Ethernet показывает нам две стороны одной медали — высокую производительность и риск потери кадров. У Fibre Channel ситуация зеркальная: гарантированная сохранность данных и невысокая пропускная способность. В то же время Ethernet демонстрирует полную унификацию в управлении и развертывании сервисов, в том числе автоматизированном.

Снова обратимся к преимуществам Fibre Channel. Это управление потоком на основе кредита, способность ресурсов быстро находить друг друга (plug’n’play), быстрые механизмы сходимости на уровне NVMe-фабрики. Если active/standby switchover в сетях Fibre Channel занимает менее одной секунды, то сети Ethernet на это потребуется от 8 до 15 секунд.

В Huawei очень хорошо понимают эти особенности, поэтому приложили серьезные усилия к тому, чтобы устранить свойственные Ethernet недостатки, сохранив при этом все его достоинства.

Анализ tcp-сессий на основе erspan

Здесь используется удаленное копирование заголовков пакетов TCP, подлежащих анализу, через протокол ERSPAN в коллектор iMaster NCE-FabricInsight для анализа сеанса TCP. CloudEngine зеркалирует пакеты TCP SYN, FIN и RST в коллектор iMaster NCE-FabricInsight.

iMaster NCE-FabricInsight анализирует полученные заголовки для анализа процессов установки и завершения TCP-соединения между приложениями в сети, для получения пути пересылки, задержки пути, времени начала/окончания и количества байтов потоков TCP, а также аномальных сеансов TCP.

Внимательный читатель скажет: «Хорошо, с TCP-трафиком разобрались. А как же RoCE, который работает по UDP, или c VxLAN пакетами на уровне SPINE?» С ним мы тоже умеем полноценно работать.

Почему?

😪Мы тщательно прорабатываем каждый фидбек и отвечаем по итогам анализа. Напишите, пожалуйста, как мы сможем улучшить эту статью.

Начальная конфигурация коммутатора huawei на примере s5720 — xcat

В данной статье хочу разобрать базовую настройку коммутатора на примере.

Имеется коммутатор Huawei S5720-52X-PWR-SI-AC. Устройство будет установлено в качестве коммутатора уровня доступа для пользователей офиса.

Требования такие:

  1. Подключения к уровню распределения агрегированным интерфейсом LACP
  2. Использование на пользовательских портах voice VLAN (для подключения ПК и IP телефона через один порт)
  3. Отдельный VLAN для сети принтеров и МФУ
  4. Подключение WI-FI точек trunk портом c PVID management VLAN
  5. Использование механизма DHCP snooping во всех VLAN

Итак поехали.

переходим в режим конфигурации:

<huawei>system-view

Даем имя коммутатору, например acess switch 01 — «ASW-01»:

[huawei]sysname ASW-01

Поскольку у нас будет использоваться voice vlan, телефоны будут получать информацию от коммутатора по протоколу LLDP или CDP по умолчанию у Cisco, совместимость с CDP включим, когда будем настраивать интерфейсы а пока на коммутаторе глобально включим LLDP:

[ASW-01]lldp enable

Для использования DHCP snooping нам потребуется включить на коммутаторе глобально DHCP и, непосредственно DHCP snooping:

[ASW-01]dhcp enable
[ASW-01]dhcp snooping enable

Теперь перейдем к VLAN, создаем VLAN для management:

[ASW-01]vlan 100
[ASW-01-vlan100]description Management

включим в этом VLAN DHCP snooping

[ASW-01-vlan100]dhcp snooping enable

выходим из настройки VLAN

[ASW-01-vlan100]quit

Аналогичным образом создаем остальные VLAN, я для примера создаю следующие VLAN:
200 — VoIP
300 — Office
400 — Printer

C VLAN разобрались, переходим к настройке доступа к коммутатору. Для начала создаем пользователя admin и назначаем ему пароль pa$$w0RD:

[ASW-01]aaa
[ASW-01-aaa]local-user admin password irreversible-cipher pa$$w0RD

назначаем пользователю уровень привилегий (15 самый высокий):

[ASW-01-aaa]local-user admin privilege level 15

включаем доступ по SSH для пользователя:

[ASW-01-aaa]local-user admin service-type telnet terminal ssh

отключаем запрос смены пароля по истечению определенного промежутка времени (это опционально, если хотите что бы устройство запрашивало смену пароля можно этого не делать):

[ASW-01-aaa]undo local-aaa-user password policy administrator
[ASW-01-aaa]quit

Теперь перейдем к включению SSH на устройстве:

[ASW-01]stelnet server enable
[ASW-01]ssh authentication-type default password

Создаем пару ключей для SSH:

[ASW-01]rsa local-key-pair create

Включаем доступ по SSH на линиях:

[ASW-01]user-interface vty 0 4
[ASW-01-ui-vty0-4]authentication-mode aaa
[ASW-01-ui-vty0-4]protocol inbound ssh
[ASW-01-ui-vty0-4]quit

Далее переходим к настройке интерфейса по которому будет доступ на коммутатор. Ранее было решено для менеджмента использовать VLAN 100. Переходим к конфигурации интерфейса этого VLAN и назначаем коммутатору IP:

[ASW-01]interface Vlanif 100
[ASW-01-Vlanif10]ip address 10.0.0.10 24
[ASW-01-Vlanif10]quit

Настраиваем шлюз по умолчанию:

[ASW-01]ip route-static 0.0.0.0 0.0.0.0 10.0.0.1

Перейдем к настройке UpLink интерфейса, как описано в требованиях выше, нам требуется собрать агрегированный интерфейс используя протокол LACP, использовать будем 10Gbit интерфейсы, имеющиеся в коммутаторе Huawei S5720-52X. У Huawei это называется Ether-Trunk, первым делом объявляем Ether-Trunk 1 и «проваливаемся» в его настройку:

[ASW-01]interface Eth-Trunk 1

затем указываем, какие порты будут являться членами агрегированного интерфейса, в данном случае я выбрал 2 10Gbit интерфейса:

[ASW-01-Eth-Trunk1]trunkport XGigabitEthernet 0/0/1 to 0/0/2

указываем протокол LACP:

[ASW-01-Eth-Trunk1]mode lacp

После этого можно конфигурировать порт в соответствии с нуждами, в нашем случае это будет trunk порт смотрящий в сторону ядра, разрешаем на нем все имеющиеся на коммутаторе VLAN и делаем его доверенным для DHCP snooping, по скольку это UpLink :

[ASW-01-Eth-Trunk1]port link-type trunk
[ASW-01-Eth-Trunk1]port trunk allow-pass vlan all
[ASW-01-Eth-Trunk1]dhcp snooping trusted
[ASW-01-Eth-Trunk1]quit

С UpLink закончили, теперь, наконец, можно перейти к настройке пользовательских портов.

Допустим порты с 1 по 46 будут использоваться для подключения телефонов и ПК пользователей, т.е. на этих портах нужно настроить voice и acces VLAN:

[ASW-01]interface range GigabitEthernet 0/0/1 to GigabitEthernet 0/0/46

Настройка порта к которому требуется подключать и телефон и ПК у Huawei отличается от привычной настройки на Cisco, здесь используется тип порта hybrid, после чего назначается voice vlan и дополнительно он добавляется на порт в качестве tagged:

[ASW-01-port-group]port link-type hybrid
[ASW-01-port-group]voice-vlan 200 enable
[ASW-01-port-group]port hybrid tagged vlan 200

В качестве untagged VLAN и PVID указываем тот что используется для ПК:

[ASW-01-port-group]port hybrid pvid vlan 300
[ASW-01-port-group]port hybrid untagged vlan 300

т.к. порт пользовательский отключаем состояния listening и learning для stp (аналог spanning tree portfast в Cisco)

[ASW-01-port-group]stp edged-port enable

наконец, включаем совместимость с протоколом CDP (cisco discover protocol) на случай если будут использоваться телефоны Cisco, добавляем description и выходим из конфигурации группы портов:

[ASW-01-port-group]lldp compliance cdp receive
[ASW-01-port-group]description Users
[ASW-01-port-group]quit

Порт 47 будем использовать для подключения МФУ, т.е. это будет просто access порт с VLAN для мфу и принтеров:

[ASW-01]interface GigabitEthernet 0/0/47
[ASW-01-GigabitEthernet0/0/47]port link-type access
[ASW-01-GigabitEthernet0/0/47]port default vlan 400
[ASW-01-GigabitEthernet0/0/47]description Printer
[ASW-01-GigabitEthernet0/0/47]quit

Порт 48 используем для подключения точки доступа WI-FI, на которой есть несколько SSID и значит этот порт должен быть в режиме trunk, а для менеджмента точки используется Management VLAN, значит в качестве PVID на этом порту будет Management VLAN.

[ASW-01]interface GigabitEthernet 0/0/48
[ASW-01-GigabitEthernet0/0/48]port link-type trunk
[ASW-01-GigabitEthernet0/0/48]port trunk pvid vlan 100
[ASW-01-GigabitEthernet0/0/48]port trunk allow-pass vlan all
[ASW-01-GigabitEthernet0/0/48]description WirelessAP
[ASW-01-GigabitEthernet0/0/48]quit

На этом первичная настройка, в соответствии с изначальными требованиями закончена. Не забываем сохранить конфигурацию, для этого нужно выйти из режима system view, нажав комбинацию клавиш Ctrl Z и дав команду save:

<ASW-01>save
The current configuration (excluding the configurations of unregistered boards or cards) will be written to flash:/vrpcfg.zip.
Are you sure to continue?[Y/N]y

PROFIT!

Больше про Хуавей:  Не включается браслет Honor Band 5 после обновления и разрядки: причины, что делать?

Настройка имени хоста

В интерфейсе командной строки имя хоста (имя устройства) заключено в угловые скобки (…) или квадратные скобки ([…]). Имя хоста по умолчанию — Huawei, но это имя следует изменить, чтобы лучше различать несколько устройств.

Настройка системного времени

По умолчанию устройства Huawei используют Coordinated Universal Time (UTC). Чтобы указать другой часовой пояс для устройства, выполните команду сlock timezone time-zone-name {add | minus} offset. Вы можете назвать часовой пояс в параметре time-zone-name и указать, является ли смещение часового пояса к UTC положительным (add offset) или отрицательным (minus offset).

[Huawei-AR-01] clock timezone BJ add 08:00

После установки часового пояса выполните команду clock datetime HH:MM: SS YYYY-MM-DD для установки времени и даты. Параметр HH:MM:SS задает время в 24-часовом формате, а YYYY-MM-DD-дату. (Устройства Huawei поддерживают только 24-часовой формат.) Например, чтобы установить время и дату 18: 30 10 марта 2022 года, выполните следующую команду:

[Huawei-AR-01] clock datetime 18:30:00 2022-03-10

Задание IP-адреса на устройстве

Для входа в систему, вы можете использовать Telnet . Однако Telnet требует, чтобы на интерфейсе устройства был установлен IP-адрес. Для присвоения IP-адреса, выполните команду ip-address {mask | mask-length} в интерфейсном виде.

Параметры ip-address и mask задают IP-адрес и маску подсети соответственно в десятичной системе счисления, а mask-length задает число последовательных «1»в двоичной системе счисления маски подсети. В следующем примере показано, как установить IP-адрес 10.1.1.100 и маску подсети 255.255.255.0 для интерфейса управления Ethernet 1/0/0:

Длина двоичной записи маски подсети равна 24 (255.255.255.0 эквивалентна двоичному значению 11111111.11111111.11111111.00000000), поэтому в этом примере вы можете заменить 255.255.255.0 на 24.

Анализ tcp anyflow

При пересылке пакета, коммутатор CloudEngine с чипом Р5 анализирует пакет и создает аппаратную таблицу потоков на основе 5-tuple. По истечении определенного времени (flow table age timeout) коммутатор CloudEngine отправляет пакет с таблицей потоков в центральный процессор для анализа и предварительной обработки.

Центральный процессор в первую очередь отправляет записи о аномальных потоках напрямую в iMaster NCE-FabricInsight для анализа и поиска неисправностей root-case. Затем центральный процессор сжимает все остальные записи потоков, генерирует таблицу статистических потоков и отправляет ее в iMaster NCE-FabricInsight для сбора статистики трафика и анализа тенденций.

Дополнительно чип P5 коммутатора CloudEngine может обнаруживать аномалии при пересылке пакетов. При обнаружении аномалии (например, задержка в пересылке пакетов превышает пороговое значение или во время пересылки происходит потеря пакетов) чип отправляет аномальный пакет в центральный процессор для создания записи потока.

Ниже приведена сравнительная таблица по трем методам анализа

Базовая конфигурация

Пользовательский режим

После авторизации на устройстве, сразу войдите в пользовательский режим, можно выполнить только несколько команд для просмотра конфигурации;

Режим просмотра

В пользовательском режиме введите system-view, чтобы войти в режим просмотра, и выполните команды для глобальной конфигурации устройства;

Режим локальной конфигурации

В режиме просмотра введите команду локальной конфигурации, например interface GE 1/0/0, чтобы войти в режим конфигурации порта GE1 / 0/0,

Кроме того, существует множество режимов локальной конфигурации.Вы можете войти в режим конфигурации VLAN, режим конфигурации агрегации портов и т. Д. В соответствии с различными потребностями. Вы можете войти? Чтобы просмотреть, какие команды могут быть выполнены в текущем режиме;

Введите quit, чтобы вернуться в предыдущий режим конфигурации, введите commit, чтобы отправить существующую конфигурацию, и введите save в пользовательском режиме, чтобы сохранить конфигурацию;

Изменить имя устройства

[~HUAWEI]sysname CE6800

Если фиксации нет, нужно один раз выйти из режима просмотра системы и сохранить;

 Настроить информацию об описании устройства

Добавьте описание устройства входа, например: Только администратор может настраивать оборудование.

Как начать использовать ethernet nof

Ниже представлены модели коммутаторов, которые Huawei в настоящее время поставляет для нужд ЦОД. Устройства принадлежат к нескольким поколениям. Некоторые снабжены AI-чипами (Edge Intelligence), но все же не обладают всем спектром возможностей, которые демонстрируют новейшие коммутаторы на нашей собственной аппаратной базе.

Модели CE6866, CE8851 также поддерживают технологию iLossless и хорошо подойдут для реализации BackEnd сети СХД на основе Ethernet NOF. CloudEngine 6866 является leaf-коммутатором с интерфейсом 25G в сторону клиента. CloudEngine 8851 — spine-коммутатор с интерфейсами 100G «вниз» и 400G «наверх».

Какие устройства поддерживают tcp anyflow

В настоящее время TCP AnyFlow реализован в новейших моделях коммутаторов:

Каким требованиям должна отвечать такая сеть

В первую очередь здесь не обойтись без управления потоком на основе кредита (Credit-based Flow Control). Того самого, который обеспечивает нулевую потерю пакетов в сетевой фабрике. Кроме того, требуется поддержка клиентской части — операционных систем, приложений.

Что касается минимальных задержек, на этом поле играют протоколы Fibre Channel, InfiniBand и Ethernet (RoCEv2). Также необходимо снять нагрузку с процессоров, что обычно делается на уровне сетевых интерфейсных карт. Наконец, на уровне архитектуры сети должна быть реализована концепция Multi-Pod, а также организована работа с системами Multi-host/Port/Path.

Среди всех способных обеспечить минимальные задержки протоколов Huawei делает ставку на Ethernet и RoCEv2 (RDMA over Converged Ethernet). Именно они позволяют объединить все составляющие сети ЦОД в одну. Уже сейчас мы видим, что многие из наших клиентов, заинтересованные в высокопроизводительных вычислениях, готовы к переходу на Ethernet, особенно после появления стандарта 400G.

Коммутаторы. коммутаторы для интернета — продукты huawei

• До 8 нисходящих портов GE и 2 восходящих порта 10 GE;

• Коммутационная ёмкость 168 Гбит/с;

• Диапазон температур эксплуатации от –40°C до 75°C, степень защиты корпуса по IP Code — IP55;

• Умный механизм обнаружения неисправностей обеспечивает интеллектуальные операции O&M.

Настроить ip интерфейса

Схема топологии выглядит следующим образом:

Конфигурация CE6800

[* CE6800] отменить пакетный коммутатор портов GE 1/0/0 GE 1/0/0 Открытая трехуровневая пересылка

[* CE6800] interface GE 1/0/0 ,,,, войдите в режим настройки интерфейса

[* CE6800-GE1 / 0/0] IP-адрес 10.0.12.1 24 Настройка IP-адреса и сетевой маски

[* CE6800-GE1 / 0/0] описание этого порта для подключения к CE12800 GE 1/0/0 Добавить описание порта (необязательно)

[* CE6800-GE1 / 0/0] отменить выключение Активация интерфейса

[* CE6800-GE1 / 0/0] quit Выйти из режима настройки интерфейса выход из режима настройки интерфейса

[* CE6800] commit Зафиксировать конфигурацию

Просмотрите конфигурацию после сохранения:

Конфигурация CE12800

Больше про Хуавей:  Как настроить переадресацию на Хоноре? — Ваша онлайн энциклопедия

Настройте адрес GE 1/0/0 как 10.0.12.1 24

Остальная часть конфигурации такая же, как у CE6800, проверьте результаты конфигурации следующим образом

Отправьте эхо-запрос однорангового узла CE12800 от CE6800 для проверки возможности подключения

Настроить аутентификацию входа aaa

сертификация aaa

Аутентификация (аутентификация), авторизация (авторизация), сокращение (учет), является механизмом управления сетевой безопасностью; Аутентификация — это локальная аутентификация / авторизация, авторизация и учет обслуживаются удаленным радиусом (система удаленной аутентификации по набору номера) или сервер hwtacacs (Система контроля доступа к терминалам Huawei) выполняет аутентификацию / авторизацию;

Войдите в режим конфигурации VTY

Настроить аутентификацию для входа с зашифрованным текстом

Войдите в режим конфигурации VTY, 0 4 означает разрешение 5 одновременных подключений Telnet

Настроить маршрут по умолчанию

В этой топологии маршруты по умолчанию настроены на CE6800 и CE6850, и они также могут пинговать друг друга. Пример конфигурации следующий:

Конфигурация CE6800:

[~CE6800]ip route-static 0.0.0.0 0.0.0.0 10.0.12.2

Конфигурация CE6850:

[~HUAWEI]ip route-static 0.0.0.0 0.0.0.0 8.0.10.1

Посмотреть таблицу маршрутизации отдельно:

Используя маршрут по умолчанию, устройства на обоих концах топологии также могут пинговать друг друга;

Настроить статическую маршрутизацию

Как и в предыдущем случае, схема топологии выглядит следующим образом:

Цель: позволить CE6800 пинговать 8.0.10.2 на CE6850

На CE12800 настройте IP-адрес интерфейса GE 1/0/1 на 8.0.10.1/24.

На CE6850 настройте GE 1/0/0 IP интерфейса 8.0.10.2/24.

После подключения к сети попробуйте выполнить эхо-запрос 8.0.10.2 на CE6850 с CE6800, но эхо-запрос не работает;

Проверьте таблицу маршрутизации CE6800, нет маршрута к 8.0.10.0/24

Добавьте статический маршрут в 8.0.10.0/24 на CE6800, адрес следующего перехода должен быть 10.0.12.2 на CE12800

[*CE6800]ip route-static 8.0.10.0 24 10.0.12.2

Затем попробуйте выполнить эхо-запрос 8.0.10.2 на CE6850 с CE6800, но пинг по-прежнему не выполняется.

Причина в том, что CE6850 не имеет маршрута к сетевому сегменту 10.0.12.0/24, что приводит к тому, что пакет данных ping «идет и не возвращается»;

Добавьте статический маршрут к 10.0.12.0/24 на CE6850, адрес следующего перехода должен быть 8.0.10.1 на CE12800

[~CE6850]ip route-static 10.0.12.0 24 8.0.10.1

После отправки и сохранения CE6800 может пинговать 8.0.10.2 на CE6850;

Проверьте таблицы маршрутизации CE6800, CE12800 и CE6850, как показано на рисунке ниже соответственно.

Обратите внимание, что поле Proto бывает двух типов: прямое и статическое.

Все маршруты CE12800 подключены напрямую, а в поле Pre установлено значение 0.

CE6800 и CE6850 имеют два статических маршрута, поле Pre — 60,

Pre представляет приоритет маршрутизации, чем меньше, тем лучше, маршрут будет сопоставлен первым;

Приоритет протокола по умолчанию для маршрутизаторов Huawei следующий.

Остальные соглашенияПротокол динамической маршрутизации,включают:

OSPF (протокол первого открытого кратчайшего пути)

RIP (протокол информации о маршрутизации)

IS-IS (протокол от промежуточной системы к промежуточной системе)

BGP (протокол пограничного шлюза)

Настроить супер-пароль устройства

Супер пароль

Когда полномочия пользователя низкие (например, при входе в систему через Telnet, уровень полномочий может быть определен как 0 или 1), в это время

Вы можете использовать суперкоманду для повышения привилегий. Чтобы избежать вреда от незаконного повышения привилегий, его следует настроить

Супер пароль защищает.

Установите супер-пароль для CE6800, пароль хранится в простом (открытый текст) режиме (эмулятор не поддерживает)

[*CE6800]super password simple huawei

Настройка стекирования (istack)

После получения доступа к коммутаторам, при необходимости можно настроить стек.  Для объединения нескольких коммутаторов в одно логическое устройство в Huawei CE используется технология iStack. Топология стека — кольцо, т.е. на каждом коммутаторе рекомендуется использовать минимум 2 порта. Количество портов зависит от желаемой скорости взаимодействия коммутаторов в стеке.

Желательно при стекировании задействовать аплинки, скорость которых обычно выше, чем у портов для подключения конечных устройств. Таким образом, можно получить большую пропускную способность при помощи меньшего количества портов. Также, для большинства моделей есть ограничения по использованию гигабитных портов для стекирования. Рекомендуется использовать минимум 10G порты.

Есть два варианта настройки, которые немного отличаются в последовательности шагов:

  1. Предварительная настройка коммутаторов с последующим их физическим соединением.

  2. Сначала установка и подключение коммутаторов между собой, потом их настройка для работы в стеке.

Последовательность действий для этих вариантов выглядит следующим образом:

Последовательность действий для двух вариантов стекирования коммутаторов
Последовательность действий для двух вариантов стекирования коммутаторов

Рассмотрим второй (более длительный) вариант настройки стека. Для этого нужно выполнить следующие действия:

  1. Планируем работы с учётом вероятного простоя. Составляем последовательность действий.

  2. Осуществляем монтаж и кабельное подключение коммутаторов.

  3. Настраиваем базовые параметры стека для master-коммутатора:

    [~HUAWEI] stack

3.1. Настраиваем нужные нам параметры
3.2 Настраиваем интерфейс порта стекирования (пример)

Далее, нужно сохранить конфигурацию и перезагрузить коммутатор:

4. Выключаем порты для стекирования на master-коммутаторе (пример)

[~SwitchA] interface stack-port 1/1
[*SwitchA-Stack-Port1/1]
shutdown
[*SwitchA-Stack-Port1/1]
commit

5. Настраиваем второй коммутатор в стэке по аналогии с первым:

system-view
[~HUAWEI] sysname
SwitchB
[*HUAWEI]
commit
[~SwitchB]
stack
[~SwitchB-stack]
stack member 1 priority 120
[*SwitchB-stack]
stack member 1 domain 10
[*SwitchB-stack]
stack member 1 renumber 2 inherit-config
Warning: The stack configuration of member ID 1 will be inherited to member ID 2
after the device resets. Continue? [Y/N]:
y
[*SwitchB-stack]
quit
[*SwitchB]
commit

Настраиваем порты для стекирования. Обратите внимание, что несмотря на то, что была введена команда “stack member 1 renumber 2 inherit-config”, member-id в конфигурации используется со значением “1” для SwitchB. 

Так происходит, потому что member-id коммутатора будет изменён только после перезагрузки и до неё коммутатор по-прежнему имеет member-id, равный 1. Параметр “inherit-config” как раз нужен для того, чтобы после перезагрузки коммутатора все настройки стека сохранились для member 2, которым и будет коммутатор, т.к. его member ID был изменён со значения 1 на значение 2.

[~SwitchB] interface stack-port 1/1[*SwitchB-Stack-Port1/1] port member-group interface 10ge 1/0/1 to 1/0/4Warning: After the configuration is complete,1.

The interface(s) (10GE1/0/1-1/0/4) will be converted to stackmode and be configured with the port crc-statistics trigger error-down command if the configuration doesnot exist.2.The interface(s) may go Error-Down (crc-statistics) because there is no shutdown configuration on theinterfaces.Continue? [Y/N]: y[*SwitchB-Stack-Port1/1] commit[~SwitchB-Stack-Port1/1] return

Перезагружаем SwitchB

save
Warning: The current configuration will be written to the device. Continue? [Y/N]:
y
reboot
Warning: The system will reboot. Continue? [Y/N]:
y

6. Включаем порты стекирования на master-коммутаторе. Важно успеть включить порты до завершения перезагрузки коммутатора B, т.к. если включить их после, коммутатор B снова уйдёт в перезагрузку.

[~SwitchA] interface stack-port 1/1[~SwitchA-Stack-Port1/1] undo shutdown[*SwitchA-Stack-Port1/1] commit[~SwitchA-Stack-Port1/1] return

7. Проверяем работу стека командой “display stack”

Пример вывода команды после правильной настройки

8. Сохраняем конфигурацию стека командой “save”. Настройка завершена.

Подробную информация про iStack и пример настройки iStack можно также посмотреть на сайте Huawei.

Настройте метод аутентификации входа в консоль и период ожидания

Вход в консоль: Вход в консоль по умолчанию не имеет пароля, любой проходитПоследовательная линияНепосредственно подключен к интерфейсу консоли устройства, может напрямую изменять конфигурацию, администратор может настроить пароль консоли, для входа не требуется имя пользователя, используйте консоль для первой настройки;

сверхурочная работа: После подключения к устройству, если в течение некоторого времени не выполняются никакие операции, система автоматически выйдет из системы и потребуется снова войти в систему. Время ожидания по умолчанию составляет 10 минут;

Войдите в режим настройки консоли

Небольшой прикладной кейс

Мы сделали внедрение в одном из крупных исследовательских центров. До начала проекта в ЦОДе действительно существовали три различных сети, каждая из которых управлялась собственной командой эксплуатации. Несмотря на это, в ЦОДе наблюдались проблемы с распределением ресурсов.

Мы полностью разработали дизайн и показали, как осуществить миграцию. После проведения PoC-тестов началась реализация проекта. Итоговый рост производительности сети составил 35–40% при значительном снижении совокупной стоимости владения инфраструктурой.

Здесь можно видеть конкретные результаты проекта. Как видите, совокупную производительность ЦОДа с учетом всех нагрузок удалось увеличить в десять раз, в том числе и за счет высвобождения ресурсов, прежде занятых обслуживанием сети.

Краткий вывод прост. Путь развития Fibre Channel довольно скоро приведет к тому, что даже самые мощные вычислительные ядра не смогут себя проявить из-за ограничения пропускной способности сети. Современный Ethernet в сочетании с решениями Huawei позволяет полностью решить эту проблему.

Больше про Хуавей:  Обзор Huawei MediaPad T3 10: оптимальный минимум

Новый ethernet без потерь

Начнем с препятствующего потере кадров управления потоком. Да, существует множество стандартизированных методов сохранения данных в Ethernet, но они решают не все проблемы. Например, они не справляются, когда трафик с множества портов сходится в один порт (incast traffic).

Чтобы решить все эти проблемы, Huawei добавил коммутаторам вычислительной мощности и реализовал на их базе сильные алгоритмы аналитики и управления состоянием очередей самого коммутатора, а также его ближайших соседей.

Вернемся к сходимости NVMe-фабрики. В случае разрушения сети протокольная сходимость осуществляется по таймауту. Мы в Huawei не считаем это правильным. Мы научились встраиваться в сигнализацию NVMe между хостом и таргетом, а затем отдавать команду произвести активный switchover на другой канал. Это позволило добиться такого же односекундного переключения, как и в сетях Fibre Channel.

Теперь о plug’n’play. Раньше для каждого ресурса приходилось вручную настраивать хост, путь, порт, имя и пр. C появлением в наших СХД OceanStor поддержки технологии UltraPath мы предлагаем возможность автоматической регистрации ресурсов.

А что с производительностью? Для того, чтобы ответить на этот вопрос, мы провели серию синтетических тестов с использованием СХД OceanStor V6. Для сравнения использовались сети Ethernet 25G и Fibre Channel 32G. Прирост производительности на небольших фреймах составил порядка 100% в пользу Ethernet.

С увеличением размера фреймов разрыв сокращался, но даже худший из результатов показал паритет пропускной способности. Конечно, гораздо интереснее было бы провести тестирование на реальных нагрузках. Как только наши заказчики обратятся за такой возможностью, мы с удовольствием откликнемся.

Несколько слов об алгоритмах iLossless

Выше представлена довольно информативная схема, но мы хотим взглянуть на ситуацию шире. Представьте, что на коммутаторе внезапно появляется мощное вычислительное ядро. Оно позволяет реализовать сразу четыре подхода защиты от потерь.

Вся эта функциональность и позволяет Huawei уверенно конкурировать с решениями на базе Fibre Channel, предлагая свои СХД на базе классической сети Ethernet. Работа коммутатора строится на парсинге, копировании и изучении пакетов. Коммутатору доступны все заголовки, включая заголовок InfiniBand.

Уже из него можно извлечь нужные подзаголовки, содержащие все основные характеристики потока. Эта информация отправляется в аналитический процессор, который собирает дополнительную информацию: запросы на соединение, ответы, порты, задержки, данные о потере пакетов и др.

Данные собираются со всех коммутаторов и отправляются на уровень выше — в интеллектуальную аналитическую платформу iMaster NCE-FabricInsight. Она видит реальную топологию сети и текущую ситуацию в ней. Как только повышается задержка RoCE-трафика и возникает угроза потери данных, начинается переконфигурация.

Немного подробней о сборе статистики TCP-сессий. Есть три подхода. В принципе, они отражают эволюционное развитие архитектуры чипов.

Нотносительная нумерация

Формат нумерации — тип пользовательского интерфейса номер. Как правило, устройство имеет один консольный порт (некоторые устройства могут иметь больше) и 15 пользовательских интерфейсов VTY (5 пользовательских интерфейсов VTY включены по умолчанию).

Нумерация интерфейса пользователя.

Когда пользователь входит в устройство, устройство выделяет пользователю самый низкий пронумерованный простой пользовательский интерфейс в соответствии с используемым методом входа в систему. Пользовательские интерфейсы нумеруются либо относительно, либо абсолютно.

Первое подключение

Подключение к коммутатору через консольный интерфейс
Подключение к коммутатору через консольный интерфейс

По умолчанию коммутаторы Huawei поставляются без предварительных настроек. Без конфигурационного файла в памяти коммутатора, при включении запускается протокол ZTP (Zero Touch Provisioning). Не будем подробно описывать данный механизм, отметим лишь, что он удобен при работе с большим числом устройств или для осуществления настройки удалённо. Обзор ZTP можно посмотреть на сайте производителя.

Для первичной настройки без использования ZTP необходимо консольное подключение.

Параметры подключения (вполне стандартные)

Transmission rate: 9600
Data bit (B): 8
Parity bit: None
Stop bit (S): 1
Flow control mode: None

После подключения Вы увидите просьбу задать пароль для консольного подключения.

Задаем пароль для консольного подключения

An initial password is required for the first login via the console.
Continue to set it? [Y/N]:
y
Set a password and keep it safe!
Otherwise you will not be able to login via the console.
Please configure the login password (8-16)
Enter Password:
Confirm Password:

Просто задайте пароль, подтвердите его и готово! Изменить пароль и прочие параметры аутентификации на консольном порту далее можно с помощью следующих команд:

Пример конфигурации агрегации портов

Схема топологии выглядит следующим образом:

GE1 / 0/1 — GE1 / 0/3 CE6850 напрямую подключены к GE1 / 0/1 — GE1 / 0/3 CE12808 на противоположном конце, и три канала используются как агрегация каналов (канал);

Конфигурация CE6850 выглядит следующим образом:

[~ CE6850] interface Eth-Trunk 1 Войдите в режим подконфигурации Eth-Trunk,

[* CE6850-Eth-Trunk1] mode lacp-dynamic выбор динамического режима lacp

[*CE6850-Eth-Trunk1]lacp max active-linknumber 1                                          

[*CE6850-Eth-Trunk1]least active-linknumber 1                                              

[*CE6850-Eth-Trunk1]trunkport GE 1/0/0

[*CE6850-Eth-Trunk1]trunkport GE 1/0/1

[* CE6850-Eth-Trunk1] trunkport GE 1/0/2 Добавьте три порта в Eth-Trunk 1

[* CE6850-Eth-Trunk1] commit Зафиксировать конфигурацию

Конфигурация CE12808 такая же, как у CE6850;

Просмотр конфигурации Eth-Trunk 1

Три провода устройств на обоих концах образуют агрегацию каналов, а логический интерфейс — Eth-Trunk 1.

Проверка подлинности ааа

Этот режим требует правильного сочетания имени пользователя и пароля. Использование комбинации имени пользователя и пароля повышает безопасность по сравнению с проверкой подлинности паролем. Кроме того, пользователи дифференцированы и не влияют друг на друга во время проверки подлинности. Проверка подлинности AAA обычно используется для входа по Telnet из-за ее повышенной безопасности.

Проверка подлинности пользователя.

Для гарантированного входа авторизованным пользователям, устройство поддерживает проверку подлинности паролем и проверку подлинности AAA. Так же можно входить и без проверки подлинности.

Просмотр информации об устройстве

Ключевая информация:

Версия программного обеспечения: Версия 8.130 (S6800 V800R013C00SPC560B560)

Модель устройства: HUAWEI S6800

Продолжительность спектакля: 0 дней, 0 часов, 15 минут.

Протокол lacp

LACP, основанный на стандарте IEEE802.3ax. LACP (Link Aggregation Control Protocol, Link Aggregation Control Protocol) — это протокол для динамического объединения каналов. Протокол LACP использует LACPDU (Link Aggregation Control Protocol Data Unit, Link Aggregation Control Protocol Data Unit).Блок данных протокола) И противоположный конецИнтерактивная информация。

Статическая агрегация LACP настраивается пользователем вручную, и системе не разрешено автоматически добавлять или удалять порты в группе агрегации. Группа агрегации должна содержать хотя бы один порт. Когда в группе агрегации только один порт, этот порт можно удалить из группы агрегации только путем удаления группы агрегации.

Протокол LACP порта статической агрегации включен. Когда статическая группа агрегации удаляется, ее порты-члены будут формировать одну или несколько динамических агрегаций LACP и поддерживать LACP включенным. Пользователям запрещено закрывать протокол LACP статического порта агрегации.

Динамическое агрегирование LACP — это агрегирование, которое система автоматически создает или удаляет. Добавление и удаление портов в группе динамического агрегирования выполняется протоколом автоматически. Только порты с одинаковой скоростью и дуплексными свойствами, подключенные к одному устройству и с одинаковой базовой конфигурацией, могут быть динамически агрегированы.

Сохранить и просмотреть конфигурацию

Сохраните всю информацию о конфигурации, отправьте и сохраните

[~CE6800]commit

Просмотреть все сохраненные конфигурации

[*CE6800]display saved-configuration

Просмотреть все текущие конфигурации

[*CE6800]display current-configuration

1 Звездаслабоватона троечкухорошо!просто отлично! (1 оценок, среднее: 4,00 из 5)
Загрузка...

Расскажите нам ваше мнение:

Ваш адрес email не будет опубликован. Обязательные поля помечены *